あーるPG - 社会人のデジタル生活

日曜プログラマになろうかなーと思った30代理系社会人の、キャリアアップや趣味(特にデジタル情報)の記録。らーめんとビールが好き。

invalid multibyte char (US-ASCII)

cygwinruby更新したら1.9.3になりまして、エラーが出るようになりました。
「invalid multibyte char (US-ASCII)」

1.9ではソースのエンコードがUS-ASCIIになってるそうで、cygwinutf-8とは違っちゃうんで、以下の記述が必要になるようです。ちゃんと直りました。

# encoding: utf-8

参考:http://d.hatena.ne.jp/kano4/20110607/ruby_invalid_multibyte

広告を非表示にする